Vertigo Sound
Mixdown
& Mastering Plugin Bundle VSE-2+VSC-3

VSC-3 PLUGIN — THE TRUE EMULATION OF OUR QUAD DISCRETE VCA COMPRESSOR

FEATURES OF THE VSC-3 PLUGIN:

  • Thorough Hardware Emulation With Discrete Sound
  • Maximum Musical Behavior
  • Re-Built From The Ground Up To Adapt To Modern Needs And Necessities
  • “A Rich Tone For The Modern Mix“ & Maximum Musical Behavior
  • Analog Sounding Compression From Soft To Punch
  • "It Shall Tame, It Can Level, It Will Smash, This Is The Glue That Will Give Life To The Mix”
  • "No Voodoo Needed”

+

VSE-2 Plugin — The Meticulous Emulation of our discrete Gyrator EQ VSE-2

VSE-2 Plugin

Features of the VSE-2 Plugin:

  • A Painstaking Hardware Emulation With Discrete Sound
  • Maximum Musical Behavior
  • Extreme Eqing without penalties
  • Add silky presence and a big defined low end heft to your material instantly!
  • Enhancement of the auditory threshold with our unique A.I.R. Mode

VSC-3 PLUGIN TECHNICAL SPECIFICATIONS


AVAILABLE FOR:

macOS: VST3 32 Bit & 64 BIt, AAX NATIVE, AU (V2)
WIN: VST3 32 Bit & 64 Bit, AAX NATIVE

 

VSE-2 PLUGIN TECHNICAL SPECIFICATIONS


AVAILABLE FOR:

macOS: VST2, VST3 32 Bit & 64 BIt, AAX DSP 64 Bit, AAX NATIVE 64 Bit, AU (V2)
WINDOWS: VST2, VST3 32 Bit & 64 Bit, AAX DSP 64 Bit, AAX NATIVE 64 Bit

 

GENERAL & MINIMUM SYSTEM REQUIREMENTS FOR VSC-3 and VSE-2

SUPPORTED OPERATING SYSTEMS
macOS 10.8 THROUGH 10.13
WINDOWS 7 THROUGH 10

 

PRO TOOLS 10.3.10 OR HIGHER OR ANY VST/VST3/AU-COMPATIBLE
HOST RUNNING ON A SUPPORTED OPERATING SYSTEM

 

macOS
INTEL CPU ONLY (MINIMUM 2 GHZ RECOMMENDED)

 

WINDOWS
INTEL-COMPATIBLE CPU WITH SSE2 INSTRUCTION SET (PENTIUM 4 COMPATIBLE OR HIGHER; MINIMUM 2 GHZ RECOMMENDED)

 

SYSTEM REQUIREMENTS:

DISPLAY RESOLUTION: 1440 × 900px OR 1280 × 960px OR HIGHER
MEMORY: 2 GB RAM

Plugin Bundle

Plugin Bundle

Now! Price for two Plugins
478,00 EUR 248,00 Euro
approx. 278 USD

248.00 €

Including 19% VAT

Available

Product added
Product Includes
  • Plugin Installer VSE-2 & VSC-3
  • Manual
  • Licence-Manager
Requirements
  • Windows: Win 7.x, Win, 8.x, Win 10
  • macOS: 10.8.x, 10.13.x